Introduction

If you have relied upon Microsoft Word or Microsoft Excel to track all of your project requirements, then the Requirements Management Database™ can be a little overwhelming. As the name implies, this tool is a one-to-many database – not a flat document – that can be used simultaneously by many people to manage project requirements.

This tool has a lot of features. But which features are the most important? Which are the features that you will be using on a day-to-day basis?

The purpose of this document is to illustrate the most commonly used functionality of the Requirements Management Database. It is a “Top-10” guide of features that you are likely to use. The guide starts with how you go about entering a new requirement, and continues up to how you would present the requirement to others in your team.

Specifically we will look at the following features:

1. Creating a new requirement with the Add New Requirement Wizard
2. Adding a little more general information, such as the Priority, Milestone, etc
3. Adding a Discussion Thread to track where the requirement came from
4. Linking Stakeholders (people who have an important stake in the requirement)
5. Grouping the requirement to keep the presentation relevant to your audience
6. Managing any Issues that arise with the requirement
7. Filtering the requirements
8. Tagging requirements for follow-up
9. Generating a Project Requirements Document (PRD) from the Reports
10. Reviewing the History (automatically captured) of each requirement

There are some other Wizards that you will, no doubt, find useful when working with Requirements. These include:

- Import Wizard (import Requirements from your spreadsheet)
- Email Wizard (email Requirements to linked Stakeholders)
- Microsoft Project Synchronization Wizard (simultaneously manage scheduling)

We’ll conclude by taking a peek the alternative Web Interface and Custom Process Module to the Requirements Management Database and conclude with some additional features for you to explore.

Let’s get started …
Feature #1: Add New Requirement Wizard

Quite often you will get an idea for a new requirement and you will want to enter it into the database right away (so you don’t forget it). This is easily and quickly done through the Add New Requirement Wizard.

Getting Here:
- Click the Add New button located on the left-hand-side of the Requirement Summary window
- Shortcut: enter the hot-key Ctrl-N

Type in the Name of the new requirement, and then click Next. The name can be up to 255 characters long (you can enter a longer description of the requirement later).

If you have nothing else to add to the new requirement, then click Finish. You’re done!

The requirement has now been saved into the database. You will probably need to add more information to the requirement before it is ready to be shown to others, but for now your requirement idea is safe.

Tips:
- If you have more information to add, the click the Next button instead of the Finish button. Feature #2 in this Getting Started Guide will help you further.
- You can import an existing spreadsheet of Requirements using the Import Wizard.
Feature #2: Adding General Information (Priority, Milestone, etc)

There is typically more to a requirement than just a Name: there is the requirement Priority, Milestone, Status, Description, as well as a lot of other associated information. Note that the Status typically reflects the maturity of the requirement – requirements usually start out with a Status of “New” or “Draft”, and ending up as “Accepted” into the project.

Getting Here:
- Continue the Add New Requirement Wizard (started above) by clicking the Next button
- Note that if you already clicked the Finish button then you will need to add more information to the requirement by clicking the Show Detail button.

There are, in fact, seven steps to the Add New Requirement Wizard. If you continue on with the wizard then you will be already up to Step 3. Here you will be asked to fill in the Milestone, Priority, and Status. In later steps you will be asked to fill in the Group, Stakeholder, and Description. If you don’t know what these are then it is ok to leave the fields blank.

Note the Customize button adjacent to each of the fields in the wizard. The Requirements Management Database is designed to conform to your existing process (not force you into a particular process), so you can customize each of the requirement attributes to suit your needs.

Tips:
- Quickly edit the requirement Description by using the Ctrl-D hot-key
**Feature #3: Adding a Discussion Thread**

Often the idea for a new requirement will not be your own, but will come from somebody else – a customer, an account manager, a field engineer, or an internal visionary. The idea might come during an interview with the customer, during an internal meeting, or through an email. You will not want to lose the original context for the idea as this forms part of your customer insights knowledgebase, so you will want to store it in a Discussion Thread.

**Getting Here:**
- Open the Requirement Detail window by clicking on the Show Detail button, then open the Threads tab from the requirement attribute list on the right-hand-side.
- Shortcut: click on the Edit menu and select the Add New Discussion Thread option

Give the Discussion Thread a name, then copy-and-paste the body of the discussion thread (from your email or meeting notes) into the thread detail.

**Tips:**
- Threads are linked to individual requirements, but you can find and filter related threads by clicking Options and opening the Threads tab in the Display Preferences window.
Feature #4: Linking Stakeholders

Stakeholders, as you might expect, are all the people that have a stake in the requirement being met. You will be the stakeholder for requirements that fall within your responsibility. Other stakeholders may include lead development engineers, subject matter experts, account managers, customers, and even end-user persona profiles (imaginative users of the project output).

Getting Here:

- Open the Requirement Detail window by clicking on the Show Detail button, then open the Stakeholders tab from the requirement attribute list on the right-hand-side.
- Shortcut: toggle the Summary Window Edit Shortcuts by clicking on the View menu and selecting Toggle Additional Toolbars Summary Window Edit Shortcuts. Then select the Stakeholders button and choose an Add to Requirement option.

Stakeholders can be assigned a Required Action, ranging from Action Leader to No Action Required.

Tips:

- Stakeholders have an Action Required for each requirement. You can change the default Action Required when you open the Stakeholder customization window.
- You can email Reports to linked Stakeholders with the Email Wizard.
Feature #5: Grouping Requirements

When you develop requirements you should consider your audience. Typically your audience does not want to read hundreds of requirements that are not relevant to them – they are only interested in the few requirements that they must consider. This is why you will want to **Group** related requirements together.

Getting Here:

- Open the Requirement Detail window by clicking on the *Show Detail* button, then open the *Groups* tab from the requirement attribute list on the right-hand-side.
- Shortcut: click the *Groups* button from the Summary Window Edit Shortcuts (see Feature #4 for more information about viewing these shortcuts). Then choose an *Add to Requirement* option.

The way you define **Groups** (and **Sub Groups**) is entirely up to you. Groups may be distinguished by technology line (for example, “hardware” or “software”), or by subject matter (for example, “quality” or “performance”). You will want to define your groups in advance by clicking on the *Customize* button.

Tips:

- You can **Filter** all the requirements belonging to a particular Group in the Requirement Summary Window.
- Each requirement can be linked to multiple Groups. The **Primary Group** (the Group at the top of the list in the Requirement Detail Window) has special significance and can be displayed in a column in the Requirement Summary Window.
**Feature #6: Managing Requirement Issues**

Requirements are never perfect the first time. They may be too vague. They may not match the problem that your customer is trying to solve. Or they may even contradict another requirement. Every such **Issue** that arises can be registered against each requirement.

Getting Here:

- Open the Requirement Detail window by clicking on the **Show Detail** button, then open the **Issues** tab from the requirement attribute list on the right-hand-side.

Each Issue has an **Issue Status**: “Unresolved / Urgent”, “Unresolved / Not Urgent”, or “Resolved”. Unresolved Issues can be filtered in the Requirement Summary Window.

Tips:

- The nature of the Issues is up to you. Click the **Customize** button (or click the **View** menu option and select **Issues**) to customize the types of issues that you deal with.
- Statistics concerning the number of resolved and unresolved Issues are logged in the requirement **History** detail tab (see **Feature #10** below for more information).
Feature #7: Filtering Requirements

The Requirements Management Database can contain hundreds (even thousands) of project requirements. But not all requirements are related to the next Milestone of the project, nor are they part of the Group that a development team might care about.

Getting Here:
• Click the Tools menu and then select the Show Filter Simple Filter option.
• Shortcut: Click the More button on the Requirement Summary Window.

Reports are generated using a what-you-see-is-what-you-get (WYSIWYG) format, so it is important to first filter just the requirements you want to include in a report.

Tips:
• If you cannot find the filtering options that you need with the Simple Filter then try the Advanced Filter.
• Filters can be saved after selecting the Miscellaneous tab of the Display Preferences Window and choosing Show Filter Preferences.
• The Microsoft Project Synchronization Wizard allows you to simultaneously manage the schedule of your filtered Requirements. Using the Requirements Management Database and Microsoft Project in concert allows you to determine which combination of features will produce the biggest impact and be delivered on-time and within budget.
Feature #8: Tagging Requirements

You may wish to Tag a selection of requirements that are related in a complex or unusual way. You may, for example, wish to Tag several requirements that you plan on working on today. Or you may wish to Tag a large number of requirements that comprises the scope of the entire project.

Getting Here:
- Open the Requirement Detail window by clicking on the Show Detail button, then open the Tags tab from the requirement attribute list on the right-hand-side and click the Customize button.
- Shortcut: click the Tags button from the Summary Window Edit Shortcuts.

A Tag is no more than a named flag that can be linked to one or more requirements. **Private Tags** are flags that only you can see. **Public Tags** are visible by everybody. **Baseline Tags** can be used to flag all of the requirements (even requirements spanning multiple Groups) that will be included in the project.

Tips:
- While filters may produce the same result, Tags can save you the trouble of managing a series of complex filters.
- You can Tag all of the requirements displayed in the Summary Window at once by clicking the Tags button from the Summary Window Edit Shortcuts and then selecting the Add to ALL the Requirements Listed option.
- You can create a different Baseline Tag each time the Project Requirement Document is updated – allowing you to easily track the changes between revisions.
Feature #9: Using Reports

You will want to share the requirements that make up the scope of your project with the rest of your team – perhaps in a Project Requirements Document (PRD) or similar document. This can be done by using Reports. While there are over 30 different types of reports, the most common reports are the Requirements Summary and Requirements Detail reports (at the top of the list marked with a star “*”).

Getting Here:
- Click the Report button on either the Requirement Summary Window or the Detail Window.
- Click the File menu and select the Report option.

Reports follow a what-you-see-is-what-you-get (WYSIWYG) format. You should first select which requirements to include in the report by using the Filter in the Requirement Summary Window. You can further customize the layout of the report, and the information that is included, by clicking on the Options button and updating the Display Preferences (particularly in the Columns and Rows tab and the Report tab).

Tips:
- Sharing reports is easily done by printing them to the Adobe Acrobat Writer or to the Microsoft Office Document Image Writer.
- An effective way to create a Project Requirements Document (PRD) is to attach a Summary Report to the front of a Detailed Report.
- Reports can be emailed to Stakeholders using the Email Wizard.
Feature #10: Reviewing History

The question most frequently asked by development engineers when presented with an updated set of requirements is “what’s changed since the last revision?”. Because the Requirements Management Database automatically tracks all of the History for each requirement, it is easy for you to generate a Change Report.

Getting Here:

- Open the Requirement Detail window by clicking on the Show Detail button, then open the History tab from the requirement attribute list on the right-hand-side.

Two types of History are automatically recorded. First, an Historic Event record is added to the History log each time a requirement field is updated – this can be viewed in the List View tab. Second, an Historic Snapshot is taken of the entire state of the requirement once per day when the requirement has changed – this can be viewed in the Detail View tab.

Tips:

- Change Reports are based upon the date range entered in the Summary Window Filter.
- While some Historic Events are not important, others represent major changes to the requirement. You can change whether an Historic Event is Major or Minor by clicking on the toggle box in the Report column.
- The default reporting of an Historic Event can be changed by clicking on the View menu and selecting the Historic Events option.
- Historic requirement Statistics can be viewed by clicking on the View Statistics button in the History Detail tab.
Alternative Web Interface

In addition to the Application Interface discussed above, there is an alternative Web Interface. The Web Interface is designed to provide the Consumers of Requirements (such as Development Engineers and Account Managers) with a simplified way to sort and filter just the information they need through a company Intranet.

Getting Here:

• The default location of the HTML files for the Sample Project is: C:\Program Files\Requirements Management Database\Web.

In general, the Web Interface provides just a way to view requirements – but with two exceptions: users may add, edit and delete requirement Issues and discussion Threads.

Tips:

• The Web Interface is only available when running in Multi-User Mode.
• It will need to be specially configured on your company’s Intranet to point to the current Project file.
**Custom Process Module**

Another alternative to the Application Interface is the Custom Process Module. A Custom Process Module is part of the Open Data Structure in which the user can customize the Tables, Forms, Reports and Source Code through Microsoft Access. But a Custom Process Module is special in that it has been pre-configured to conform to a particular Requirements Management process.

For example, the Blackblot Procedural Requirements Management (PRM) process has been built into a Custom Process Module that is included in your Installation Directory.
Users can access Requirements through both the Requirements Management Database and the Custom Process Module simultaneously - the data is stored in the same Project file and remains synchronized at all times.

Getting Here:
- Select the View menu and then select *Blackblot Custom Process Module*... (or *Open Data Structure*... if no Custom Process Module has been pre-built into the current Project file).
- Open Microsoft Access and from within Access open the Project file. The default location is: C:\Program Files\Requirements Management Database\Project Files\Blackblot Sample Project.mdb.

Tips:
- The **Custom Process Module** is only available through Microsoft Access.
Conclusion

Through this Getting Started Guide you should come to appreciate the Top-10 features in the Requirements Management Database that you are likely to use on a day-to-day basis. You should also be aware of the simplified Web Interface. But there are many more features ready for you to discover. Listed below are several that you might find useful:

- **Use Cases**  
  Use Cases can be used to describe the actual problem that your end-user may be suffering from, and many requirements may flow down from just several Use Cases. Alternatively, Use Cases may be used to describe how a sub-contractor will go about solving a particular problem that spans a set of requirements.

- **Export Queries**  
  In order for the Requirements Management Database to be compatible with your existing process, Export Queries may be used to export requirements into either Microsoft Word or Microsoft Excel.

- **Sub Requirements**  
  When a requirement evolves into something beyond an atomic feature request then Sub Requirements become helpful. Sub Requirements have their own Milestone and can be grouped together through their unique identification numbering scheme.

- **Associates**  
  A direct linkage (Peer-to-Peer or Parent-Child) can be made between requirements by using the Associate Requirements feature.

- **Test Cases**  
  In order to describe whether the technical fulfillment of a requirement by the development engineering team is adequate, a series of Test Cases can be created. The state of each Test Case can then be tracked to ensure project completion.

- **Custom Lists**  
  To track everything else that may be related to the requirements, such as drawings, documentation, and even items that are unique to your process, the Custom Lists feature may be used.
More Information and Feedback

We are always tracking our own enhancement requests for the Requirements Management Database. If you’d like to request that we add a new feature then please email us at: feedback@reqdb.com.

If you’d like more information about any feature, or about any service that we can provide you, please email us at: info@reqdb.com.

Good luck!